This page is a snapshot from the LWG issues list, see the Library Active Issues List for more information and the meaning of C++23 status.

3807. The feature test macro for ranges::find_last should be renamed

Section: 17.3.2 [version.syn] Status: C++23 Submitter: Daniel Marshall Opened: 2022-11-02 Last modified: 2023-11-22

Priority: Not Prioritized

View other active issues in [version.syn].

View all other issues in [version.syn].

View all issues with C++23 status.

Discussion:

The current feature test macro is __cpp_lib_find_last which is inconsistent with almost all other ranges algorithms which are in the form __cpp_lib_ranges_xxx.

Proposed resolution is to rename the macro to __cpp_lib_ranges_find_last.

[Kona 2022-11-12; Move to Ready]

[2023-02-13 Approved at February 2023 meeting in Issaquah. Status changed: Voting → WP.]

Proposed resolution:

This wording is relative to N4917.

  1. Modify 17.3.2 [version.syn], header <version> synopsis, as indicated:

    […]
    #define __cpp_lib_filesystem              201703L // also in <filesystem>
    #define __cpp_lib_ranges_find_last        202207L // also in <algorithm>
    #define __cpp_lib_flat_map                202207L // also in <flat_map>
    […]