-
Notifications
You must be signed in to change notification settings - Fork 769
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
P1020R1 Smart pointer creation with default initialization #2468
Conversation
@burblebee, could you please fix the overfull \hbox here? Thanks. |
@jensmaurer I think it's complaining about this text in utilities.tex around line 9811 because allocate_shared_default_init doesn't fit:
How to fix??? |
Feel free to add hyphenation hints ( |
I'm trying to fix similar Overfull issues in motions-2018-11-lwg-4 with no luck, using both
Oddly enough, when I misspelled How can I tell exactly what word in the line(s) it's complaining about? The Overfull warning is:
|
@tkoeppe I was able to fix motions-2018-11-lwg-18 by forcing a linebreak. It's the cleanest solution wrt readability, and there is no resulting underflow. |
template<class T, ...> | ||
shared_ptr<T> make_shared_default_init(@\placeholdernc{args}@); | ||
template<class T, class A, ...> | ||
shared_ptr<T> allocate_shared_default_init(const A& a, @\placeholdernc{args}@); |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
This seems broken (also in the ingress paper): The whole point of ..._default_init is to have no arguments, so why are we talking about "args" here? Also, the pack-like "..." in the template argument list should go.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Ah, that's to cover "size_t N" for the array case. The not-really parallelism to make_shared(args) is highly misleading.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
@jensmaurer Can you open a separate issue for this?
[memory.syn] Move return types to before function names for consistency.
a332a1d
to
5f91adf
Compare
[memory.syn] Move return types to before function names for consistency.
Fixes #2424.